<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>Vintage Car Lover “Brings ’Em Back to Life” on His Hit YouTube Show</title><meta name="description" content="Renee and Dennis Savage enjoy restoring, driving, and showing off their fantastic collection of 1956 Chevys." />
		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />

		<style type="text/css">
			.slide-excerpt { width: 50%; }
			.slide-excerpt { bottom: 0; }
			.slide-excerpt { right: 0; }
			.flexslider { max-width: 720px; max-height: 556px; }
			.slide-image { max-height: 556px; }
		</style><link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Resident &raquo; Feed" href="http://www.theresident.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Resident &raquo; Comments Feed" href="http://www.theresident.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Resident &raquo; Vintage Car Lover “Brings ’Em Back to Life” on His Hit YouTube Show Comments Feed" href="http://www.theresident.com/vintage-car-lover-brings-em-back-to-life-on-his-hit-youtube-show/feed/" />
<link rel="canonical" href="http://www.theresident.com/vintage-car-lover-brings-em-back-to-life-on-his-hit-youtube-show/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.theresident.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.10"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='news-pro-theme-css'  href='http://www.theresident.com/wp-content/themes/news-pro/style.css?ver=3.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.theresident.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-stylesheet-css'  href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8/themes/base/jquery-ui.css?ver=4.7.10' type='text/css' media='all' />
<link rel='stylesheet' id='jscrollpane-stylesheet-css'  href='http://www.theresident.com/wp-content/plugins/total-control-html5-audio-player-basic/javascripts/jscrollpane/style/jquery.jscrollpane.css?ver=4.7.10' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='http://www.theresident.com/wp-content/plugins/simple-social-icons/css/style.css?ver=2.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-tabs-stylesheet-css'  href='http://www.theresident.com/wp-content/plugins/genesis-tabs/style.css?ver=4.7.10' type='text/css' media='all' />
<link rel='stylesheet' id='slider_styles-css'  href='http://www.theresident.com/wp-content/plugins/genesis-responsive-slider/style.css?ver=0.9.5' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v5.5.4 - Universal disabled - https://www.monsterinsights.com/ -->
<script type="text/javascript">

	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-11124444-1']);
	_gaq.push(['_gat._forceSSL']);
	_gaq.push(['_trackPageview']);

	(function () {
		var ga = document.createElement('script');
		ga.type = 'text/javascript';
		ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0];
		s.parentNode.insertBefore(ga, s);
	})();

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js?ver=4.7.10'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.16/jquery-ui.min.js?ver=4.7.10'></script>
<script type='text/javascript' src='http://www.theresident.com/wp-content/plugins/total-control-html5-audio-player-basic/javascripts/soundmanager/script/soundmanager2.js?ver=4.7.10'></script>
<script type='text/javascript' src='http://www.theresident.com/wp-content/plugins/total-control-html5-audio-player-basic/javascripts/jscrollpane/script/jquery.mousewheel.js?ver=4.7.10'></script>
<script type='text/javascript' src='http://www.theresident.com/wp-content/plugins/total-control-html5-audio-player-basic/javascripts/jscrollpane/script/jquery.jscrollpane.js?ver=4.7.10'></script>
<script type='text/javascript' src='http://www.theresident.com/wp-content/plugins/total-control-html5-audio-player-basic/TotalControl.js?ver=4.7.10'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.theresident.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://www.theresident.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script>
<link rel='https://api.w.org/' href='http://www.theresident.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.theresident.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://www.theresident.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.theresident.com%2Fvintage-car-lover-brings-em-back-to-life-on-his-hit-youtube-show%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.theresident.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.theresident.com%2Fvintage-car-lover-brings-em-back-to-life-on-his-hit-youtube-show%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style><link rel="icon" href="http://www.theresident.com/wp-content/themes/news-pro/images/favicon.ico" />
<link rel="pingback" href="http://www.theresident.com/xmlrpc.php" />
<style type="text/css">.site-title a { background: url(http://www.theresident.com/wp-content/uploads/2014/09/cropped-wordpressheader.jpg) no-repeat !important; }</style>
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<style type="text/css" media="screen"> .simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #999999 !important; border-radius: 3px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 18px; padding: 9px; }  .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus { background-color: #666666 !important; border-color: #ffffff !important; color: #ffffff !important; }  .simple-social-icons ul li a:focus { outline: 1px dotted #666666 !important; }</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #225180; background-image: url("http://singlefeatherdigital.com/wp-content/uploads/2014/05/Coral-Wallpaper.jpg"); background-position: center top; background-size: auto; background-repeat: no-repeat; background-attachment: fixed; }
</style>
</head>
<body class="post-template-default single single-post postid-17904 single-format-standard custom-background custom-header header-image header-full-width content-sidebar news-pro-blue" itemscope itemtype="http://schema.org/WebPage"><div class="site-container"><header class="site-header" itemscope itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="title-area"><h1 class="site-title" itemprop="headline"><a href="http://www.theresident.com/">The Resident</a></h1><h2 class="site-description" itemprop="description">Good News That Rocks</h2></div></div></header><nav class="nav-primary" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-navigation" class="menu genesis-nav-menu menu-primary"><li id="menu-item-16082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16082"><a href="http://www.theresident.com/category/currentissue/" itemprop="url"><span itemprop="name">CURRENT ISSUE</span></a></li>
<li id="menu-item-558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-558"><a href="http://www.theresident.com/category/entertainment/" itemprop="url"><span itemprop="name">ENTERTAINMENT</span></a>
<ul class="sub-menu">
	<li id="menu-item-15671" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15671"><a href="http://www.theresident.com/category/entertainment/celebrities/" itemprop="url"><span itemprop="name">Casino</span></a></li>
	<li id="menu-item-15672" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15672"><a href="http://www.theresident.com/category/entertainment/music/" itemprop="url"><span itemprop="name">Music</span></a></li>
	<li id="menu-item-15675" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15675"><a href="http://www.theresident.com/category/entertainment/theater/" itemprop="url"><span itemprop="name">Theater</span></a></li>
	<li id="menu-item-561" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-561"><a href="http://www.theresident.com/category/entertainment/dining/" itemprop="url"><span itemprop="name">Dining</span></a></li>
</ul>
</li>
<li id="menu-item-15754" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-15754"><a href="http://www.theresident.com/category/news/" itemprop="url"><span itemprop="name">NEWS</span></a>
<ul class="sub-menu">
	<li id="menu-item-15802" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15802"><a href="http://www.theresident.com/category/news/from-the-publisher/" itemprop="url"><span itemprop="name">From the publisher</span></a></li>
	<li id="menu-item-15756" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15756"><a href="http://www.theresident.com/category/news/smartpower/" itemprop="url"><span itemprop="name">Smart Power</span></a></li>
	<li id="menu-item-16013" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16013"><a href="http://www.theresident.com/connecticut-local-news/" itemprop="url"><span itemprop="name">CONNECTICUT LOCAL NEWS</span></a></li>
</ul>
</li>
<li id="menu-item-15785" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-15785"><a href="http://www.theresident.com/category/research/" itemprop="url"><span itemprop="name">HEALTH</span></a>
<ul class="sub-menu">
	<li id="menu-item-15786" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15786"><a href="http://www.theresident.com/category/research/intimacy/" itemprop="url"><span itemprop="name">Intimacy</span></a></li>
	<li id="menu-item-15787" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15787"><a href="http://www.theresident.com/category/research/life-styles/" itemprop="url"><span itemprop="name">Life Styles</span></a></li>
</ul>
</li>
<li id="menu-item-968" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-968"><a href="http://www.theresident.com/contest/" itemprop="url"><span itemprop="name">CONTESTS</span></a></li>
<li id="menu-item-559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-559"><a href="http://www.theresident.com/category/biz/" itemprop="url"><span itemprop="name">BIZ</span></a>
<ul class="sub-menu">
	<li id="menu-item-560" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-560"><a href="http://www.theresident.com/category/biz/lte/" itemprop="url"><span itemprop="name">Letter to the Editor</span></a></li>
	<li id="menu-item-15676" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15676"><a href="http://www.theresident.com/category/biz/financial/" itemprop="url"><span itemprop="name">Financial</span></a></li>
	<li id="menu-item-15701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15701"><a href="http://www.theresident.com/category/biz/resident-business/" itemprop="url"><span itemprop="name">Residents in Business</span></a></li>
</ul>
</li>
<li id="menu-item-15702" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15702"><a href="http://www.theresident.com/category/military-2/" itemprop="url"><span itemprop="name">MILITARY</span></a>
<ul class="sub-menu">
	<li id="menu-item-15708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15708"><a href="http://www.theresident.com/category/military-2/stars-and-stripes/" itemprop="url"><span itemprop="name">Stars and Stripes</span></a></li>
	<li id="menu-item-15712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15712"><a href="http://www.theresident.com/category/military-2/veteran/" itemprop="url"><span itemprop="name">Veteran</span></a></li>
</ul>
</li>
<li id="menu-item-15788" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15788"><a href="http://www.theresident.com/category/pets/" itemprop="url"><span itemprop="name">PETS</span></a></li>
<li id="menu-item-15677" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15677"><a href="http://www.theresident.com/category/local-biz/" itemprop="url"><span itemprop="name">Sports</span></a>
<ul class="sub-menu">
	<li id="menu-item-15705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15705"><a href="http://www.theresident.com/category/local-biz/fishing/" itemprop="url"><span itemprop="name">Fishing</span></a></li>
	<li id="menu-item-15703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15703"><a href="http://www.theresident.com/category/local-biz/baseball-local-biz/" itemprop="url"><span itemprop="name">Baseball</span></a></li>
	<li id="menu-item-15706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15706"><a href="http://www.theresident.com/category/local-biz/football-local-biz/" itemprop="url"><span itemprop="name">Football</span></a></li>
	<li id="menu-item-15707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15707"><a href="http://www.theresident.com/category/local-biz/golf/" itemprop="url"><span itemprop="name">Golf</span></a></li>
	<li id="menu-item-15704" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15704"><a href="http://www.theresident.com/category/local-biz/boxing/" itemprop="url"><span itemprop="name">Boxing</span></a></li>
</ul>
</li>
<li id="menu-item-15736" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-15736"><a href="http://www.theresident.com/category/events/" itemprop="url"><span itemprop="name">EVENTS</span></a>
<ul class="sub-menu">
	<li id="menu-item-15737" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15737"><a href="http://www.theresident.com/category/events/across/" itemprop="url"><span itemprop="name">Across The Area</span></a></li>
</ul>
</li>
<li id="menu-item-478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-478"><a href="http://www.theresident.com/contact-2/" itemprop="url"><span itemprop="name">CONTACT</span></a>
<ul class="sub-menu">
	<li id="menu-item-16009" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16009"><a href="http://www.theresident.com/contact-2/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
	<li id="menu-item-15920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15920"><a href="http://www.theresident.com/friends-of-the-resident/" itemprop="url"><span itemprop="name">RESIDENT FRIENDS</span></a></li>
	<li id="menu-item-437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-437"><a href="http://www.theresident.com/templates/" itemprop="url"><span itemprop="name">About Us</span></a></li>
</ul>
</li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-17904 post type-post status-publish format-standard category-across category-announcements category-automotive category-events category-life-styles category-news category-photo tag-bring-em-back-to-life tag-dennis-savage tag-lisbon tag-new-england entry" itemscope itemtype="http://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Vintage Car Lover “Brings ’Em Back to Life” on His Hit YouTube Show</h1> 
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2018-03-23T14:39:28+00:00">March 23, 2018</time> by <span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person"><a href="http://www.theresident.com/author/resproduction/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">ResProduction</span></a></span>  </p></header><div class="entry-content" itemprop="text"><div id="attachment_17905" style="width: 1034px" class="wp-caption aligncenter"><img class="size-large wp-image-17905" src="http://www.theresident.com/wp-content/uploads/2018/03/DennisSavage-1024x604.jpg" alt="" width="1024" height="604" srcset="http://www.theresident.com/wp-content/uploads/2018/03/DennisSavage-1024x604.jpg 1024w, http://www.theresident.com/wp-content/uploads/2018/03/DennisSavage-150x89.jpg 150w, http://www.theresident.com/wp-content/uploads/2018/03/DennisSavage-300x177.jpg 300w, http://www.theresident.com/wp-content/uploads/2018/03/DennisSavage-768x453.jpg 768w" sizes="(max-width: 1024px) 100vw, 1024px" /><p class="wp-caption-text"><em>Renee and Dennis Savage enjoy restoring, driving, and showing off their fantastic collection of 1956 Chevys.</em></p></div>
<p><em>by Anna Trusky</em></p>
<p>To <strong>Dennis Savage</strong> of<strong> Lisbon</strong>, walking through an automobile salvage yard is like paying a visit to dear old friends.</p>
<p>“Salvage yards are outdoor museums for men who are interested in automotive history,” Dennis said. “They’re full of ‘memory candy,’ as I call it – old cars that remind us of times when we were younger, riding around with our parents or friends. That feeling is what I try to create with my <strong>YouTube</strong> show, <strong>‘Bring ’Em Back to Life!</strong>’”<br />
When he decided to develop a program that would share his passion for salvage yards and antique cars, Dennis joined the SECT filmmakers group so he could learn the ropes of television production. The friends he made there helped him turn his idea into a pilot and trailers, which led to showings at exhibitions and festivals.<br />
“Today, with the assistance of my grandson and awesome editor <strong>Robbie Savage, Jr., a New England Tech</strong> graduate, ‘Bring ’Em Back To Life’ is garnering tens of thousands of views and hundreds of ‘likes’ and ‘shares’ on YouTube,” Dennis said. “We’re getting new subscribers every day. There are now 14 episodes on YouTube and a new season is about to begin.”<br />
On each episode, Dennis takes his camera into a salvage yard and looks for vintage vehicles with parts that can be saved and repurposed. “Most salvage yard owners are happy to let me come into their yards. They walk with me and tell me the history. It’s good for those who are looking for parts for their antique cars to see what is out there.”<br />
Dennis himself has a “sizeable” collection of vintage <strong>’55 ’56</strong>, and<strong> ’57 Chevrolets</strong>. “We’ve been driving them all our lives,” he said. “When I’d find them in salvage yards, we’d save them and put them in our barn. We restored them and now they’re valuable antiques.”<br />
Word of Dennis’s show is spreading far and wide. “Recently I was invited to talk about the show on <strong>Mike Minarski’s Wolverine FM Radio</strong> station in<strong> Jewett City, Stu Breyer’s WICH AM Talk Radio</strong> show in<strong> Norwich</strong>, and most recently<strong> Joe Pepitone’s ‘Every Car Has A Story’</strong> on<strong> Big Talk Radio FM 106.7</strong> in<strong> Wilmington, North Carolina</strong>. My wife <strong>Renee</strong> taped us meeting in person to use on an upcoming episode,” he said.<br />
Renee, Dennis pointed out, is his faithful supporter and biggest fan. It’s no wonder since vintage Chevys have played an important role in the Savages’ life together since day one. “We just celebrated our fiftieth wedding anniversary—we eloped in my ’57 Chevrolet. That’s how our love affair with classic Chevrolets started!” Dennis said.<br />
To get in touch with Dennis, email him at <em><strong>Den567@att.net</strong> </em>or visit his Facebook page, <a href="https://www.facebook.com/Denny.Salvage" onclick="_gaq.push(['_trackEvent', 'outbound-article', 'https://www.facebook.com/Denny.Salvage', 'Dennis Savage']);" >Dennis Savage</a>.</p>
<!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.theresident.com/vintage-car-lover-brings-em-back-to-life-on-his-hit-youtube-show/"
    dc:identifier="http://www.theresident.com/vintage-car-lover-brings-em-back-to-life-on-his-hit-youtube-show/"
    dc:title="Vintage Car Lover “Brings ’Em Back to Life” on His Hit YouTube Show"
    trackback:ping="http://www.theresident.com/vintage-car-lover-brings-em-back-to-life-on-his-hit-youtube-show/trackback/" />
</rdf:RDF>-->
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://www.theresident.com/category/events/across/" rel="category tag">Across The Area</a>, <a href="http://www.theresident.com/category/events/announcements/" rel="category tag">Announcements</a>, <a href="http://www.theresident.com/category/automotive/" rel="category tag">AUTOMOTIVE</a>, <a href="http://www.theresident.com/category/events/" rel="category tag">EVENTS</a>, <a href="http://www.theresident.com/category/research/life-styles/" rel="category tag">Life Styles</a>, <a href="http://www.theresident.com/category/news/" rel="category tag">NEWS</a>, <a href="http://www.theresident.com/category/photo/" rel="category tag">PHOTO</a></span> <span class="entry-tags">Tagged With: <a href="http://www.theresident.com/tag/bring-em-back-to-life/" rel="tag">Bring ’Em Back To Life</a>, <a href="http://www.theresident.com/tag/dennis-savage/" rel="tag">Dennis Savage</a>, <a href="http://www.theresident.com/tag/lisbon/" rel="tag">Lisbon</a>, <a href="http://www.theresident.com/tag/new-england/" rel="tag">New England</a></span></p></footer></article><div class="entry-comments" id="comments"><h3>Comments</h3><ol class="comment-list">
	<li class="comment even thread-even depth-1" id="comment-28217">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/b29598e9714e744bb8a8c3adf346e4c1?s=48&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/b29598e9714e744bb8a8c3adf346e4c1?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Edie Main</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2018-03-24T05:21:41+00:00" itemprop="datePublished"><a href="http://www.theresident.com/vintage-car-lover-brings-em-back-to-life-on-his-hit-youtube-show/#comment-28217" class="comment-time-link" itemprop="url">March 24, 2018 at 5:21 AM</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>This wonderful article about America is a treasure, as is our favorite Auto Historian Dennis Savage.</p>
		</div>

		
		
	</article>
	<ul class="children">

	<li class="comment odd alt depth-2" id="comment-28220">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/026e15d09a4e97baed26c02ae05d493a?s=48&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/026e15d09a4e97baed26c02ae05d493a?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">mike</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2018-03-29T15:45:06+00:00" itemprop="datePublished"><a href="http://www.theresident.com/vintage-car-lover-brings-em-back-to-life-on-his-hit-youtube-show/#comment-28220" class="comment-time-link" itemprop="url">March 29, 2018 at 3:45 PM</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Hi I&#8217;m in need of a outter passenger  headlight  bezel  for  a  1962 ford galaxie  500  would  you have one if so would you sell it</p>
		</div>

		
		
	</article>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->

	<li class="comment even thread-odd thread-alt depth-1" id="comment-28219">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/d2ea9479f46544c5c6be663e5f9a1573?s=48&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/d2ea9479f46544c5c6be663e5f9a1573?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name"><a href="http://facebook" class="comment-author-link" rel="external nofollow" itemprop="url">MJ Palmer</a></span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2018-03-24T11:06:54+00:00" itemprop="datePublished"><a href="http://www.theresident.com/vintage-car-lover-brings-em-back-to-life-on-his-hit-youtube-show/#comment-28219" class="comment-time-link" itemprop="url">March 24, 2018 at 11:06 AM</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Great 👍 article!  It is such a joy to see Dennis &amp; Renee recognized for their life long passion for living history. Wishing them blessings in &#8220;Bringing Em Back To Life!!&#8221;</p>
		</div>

		
		
	</article>
	</li><!-- #comment-## -->
</ol></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="http://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="http://schema.org/SearchAction" method="get" action="http://www.theresident.com/" role="search"><meta itemprop="target" content="http://www.theresident.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section>
<section id="simple-social-icons-2" class="widget simple-social-icons"><div class="widget-wrap"><h4 class="widget-title widgettitle">FOLLOW US ONLINE</h4>
<ul class="alignleft"><li class="ssi-facebook"><a href="https://www.facebook.com/TheResidentGoodNews" target="_blank"><svg role="img" class="social-facebook" aria-labelledby="social-facebook"><title id="social-facebook">Facebook</title><use xlink:href="http://www.theresident.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/Resident_News" target="_blank"><svg role="img" class="social-twitter" aria-labelledby="social-twitter"><title id="social-twitter">Twitter</title><use xlink:href="http://www.theresident.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section>
        <link type="text/css" rel="stylesheet" href="http://www.theresident.com/wp-content/plugins/total-control-html5-audio-player-basic/css/default.css" />
        <script>
		 soundManager.url = "http://www.theresident.com/wp-content/plugins/total-control-html5-audio-player-basic/javascripts/soundmanager/swf";
		 var $total = jQuery.noConflict();
		$total().ready(function() {
			
			//$("body").hide();
			
			$total("#total-playlist").totalControl({
				checkboxesEnabled: true,
				playlistSortable: true, 
				playlistHeight:165,
				repeatOneEnabled: true,
				repeatAllEnabled: true,
				playlistVisible: true,
				autoplayEnabled: false				
			});
			$total(".total-playing-title, .total-playing-artist").css("line-height", "10px");
			$total("#total-playlist").css("z-index", "3000");
			
			
			
			
		});
		</script>
        <ul id="total-playlist" style="margin-left:auto; margin-right:auto;">
            <li mp3="http://www.theresident.com/wp-content/uploads/2016/08/felix.mp3" ogg="" artist="Alexis Ann appearance w/ Lee Elci" title="August 24 w/ Special Guest Felix Rappaport"></li>
            <li mp3="" ogg="" artist="" title=""></li>
            <li mp3="" ogg="" artist="" title=""></li>
            <li mp3="" ogg="" artist="" title=""></li>
            <li mp3="" ogg="" artist="" title=""></li>
         
		
        </ul>
        
        <section id="black-studio-tinymce-2" class="widget widget_black_studio_tinymce"><div class="widget-wrap"><h4 class="widget-title widgettitle">Advertisement</h4>
<div class="textwidget"><p><a href="http://www.theresident.com/wp-content/uploads/2014/08/AdvertisePromo_Color1.jpg"><img class="alignnone  wp-image-16419" src="http://www.theresident.com/wp-content/uploads/2014/08/AdvertisePromo_Color1.jpg" alt="AdvertisePromo_Color" width="341" height="256" /></a></p></div></div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="http://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2018 &#x000B7; <a href="http://my.studiopress.com/themes/news/">News Pro Theme</a> on <a href="http://www.studiopress.com/">Genesis Framework</a> &#x000B7; <a href="http://wordpress.org/">WordPress</a> &#x000B7; <a href="http://www.theresident.com/wp-login.php">Log in</a></p></div></footer></div><script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",animation: "slide",directionNav: 1,controlNav: 0,animationDuration: 1000,slideshowSpeed: 6000    });  });</script><script type='text/javascript' src='http://www.theresident.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.theresident.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.6'></script>
<script type='text/javascript' src='http://www.theresident.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.theresident.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.theresident.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.theresident.com/wp-content/plugins/genesis-responsive-slider/js/jquery.flexslider.js?ver=0.9.5'></script>
<script type='text/javascript' src='http://www.theresident.com/wp-includes/js/wp-embed.min.js?ver=4.7.10'></script>
<script type="text/javascript">jQuery(document).ready(function($) { $(".ui-tabs").tabs(); });</script>
<!-- Clicky Web Analytics - https://clicky.com, WordPress Plugin by Yoast - https://yoast.com/wordpress/plugins/clicky/ --><script type='text/javascript'>
	function clicky_gc(name) {
		var ca = document.cookie.split(';');
		for (var i in ca) {
			if (ca[i].indexOf(name + '=') != -1) {
				return decodeURIComponent(ca[i].split('=')[1]);
			}
		}
		return '';
	}
	var username_check = clicky_gc('comment_author_66ebf66d21ff686cafc060378440e760');
	if (username_check) var clicky_custom_session = {username: username_check};
</script>
<script type="text/javascript">
	var clicky_custom = clicky_custom || {}; clicky_custom.cookies_disable = 1;
	var clicky = { log : function () { return true;	}, goal: function () { return true;	} };
	var clicky_site_id = 100746879;
	(function () {
		var s = document.createElement('script');s.type = 'text/javascript';s.async = true;s.src = '//static.getclicky.com/js';
		( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild(s);
	})();
</script>
<noscript><p><img alt="Clicky" width="1" height="1" src="//in.getclicky.com/100746879ns.gif" /></p></noscript>
</body></html>

<!--Generated by Endurance Page Cache-->